re = /(?s)^\s*<\?php(?!.*\?>\s*$).*+$/
str = '<?php or whitespace
whitespace ?> '
# Print the match result
str.match(re) do |match|
puts match.to_s
end