import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\#\\#\\#\\#\\#\\#PROJECT\\s+Name:\\s+(?P<PROJECT_NAME>.+?)\\#\\#\\#\\#\\#\\#\n"
+ ".+?\n"
+ "(?P<OVERLOAD>OVERLOAD\\(%\\)(?:\\s+\\d+\\.\\d+){4}).+?\n"
+ "(?P<LOSS_OF_LOAD>LOSS\\s+OF\\s+LOAD\\s+\\(M\\)(?:\\s+\\d+\\.\\d+){4})";
final String string = "######PROJECT Name: ABCD######\n"
+ "foo\n"
+ "bar \n"
+ "baz\n"
+ "OVERLOAD(%) 0.3361 10.0 3.4 2.49 1\n"
+ "LOSS OF LOAD (M) 10.5780 10.0 105.8 14026.67 11\n\n"
+ "######PROJECT Name: ABCD2######\n"
+ "foo\n"
+ "bar \n"
+ "baz\n"
+ "OVERLOAD(%) 0.3361 10.0 3.4 2.49 1\n"
+ "LOSS OF LOAD (M) 10.5780 10.0 105.8 14026.67 11";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}