#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*(\.((?![^\.]$)[^\.]*)$)|.*@(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)$))(?=^.{6,320}$)(?:[a-zA-Z0-9áàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-zA-Z0-9áàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ!#$%&'*+\/=?^_`{|}~-]+)*|"(?:[\xE1\xE0\xE2\xE4\xE3\xE5\xE7\xE9\xE8\xEA\xEB\xED\xEC\xEE\xEF\xF1\xF3\xF2\xF4\xF6\xF5\xFA\xF9\xFB\xFC\xFD\xFF\xE6\xC1\xC0\xC2\xC4\xC3\xC5\xC7\xC9\xC8\xCA\xCB\xCD\xCC\xCE\xCF\xD1\xD3\xD2\xD4\xD6\xD5\xDA\xD9\xDB\xDC\xDD\xC6\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f\s]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])*")(?:(?=@(?:[0-9]{1,3}.){3}[0-9]{1,3})@(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))$|(?!@(?:[0-9]{1,3}.){4,}$)@(?:(?:[a-zA-Z0-9áàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ](?:[a-zA-Z0-9áàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ-]*[a-zA-Z0-9áàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ])?\.)+[a-zA-Z0-9áàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ](?:[a-zA-Z0-9áàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ-]*[a-zA-Z0-9áàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ])?)$)"
Local $sString = "jeu de test invalides" & @CRLF & _
                "-----------" & @CRLF & _
                "a@123.123.123.123.123" & @CRLF & _
                "a@123.123.123.123.5" & @CRLF & _
                "a@222.333.666.888" & @CRLF & _
                "a@322.111.222.001" & @CRLF & _
                "a@29.99.352.001" & @CRLF & _
                "a@124.124.14..124" & @CRLF & _
                "a@a.f" & @CRLF & _
                "a@.fr" & @CRLF & _
                "adresse.de.321.caracteres@bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa@bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb.bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb.cccccccccc" & @CRLF & _
                ".bds@finances.gouv.fr.edu.com" & @CRLF & _
                "bds.@finances.gouv.fr.edu.com" & @CRLF & _
                "" & @CRLF & _
                "" & @CRLF & _
                "jeu de test valides" & @CRLF & _
                "-----------" & @CRLF & _
                "a@222.111.11.2.tutu.com" & @CRLF & _
                "a@222.111.11.333.com" & @CRLF & _
                "a@222.111.com" & @CRLF & _
                "a@22d2.11d1.com" & @CRLF & _
                "a@29.99.252.001" & @CRLF & _
                "a@022.111.222.001" & @CRLF & _
                "a@124.124.124.124" & @CRLF & _
                "a@111.111.111.111" & @CRLF & _
                "a@222.5.22.001" & @CRLF & _
                "této@194.168.12.5" & @CRLF & _
                "abc@a.b.c.azertyuiop" & @CRLF & _
                "a@b.fr" & @CRLF & _
                ""Abc@def"@example.com" & @CRLF & _
                "def@example.com" & @CRLF & _
                "a@b.com" & @CRLF & _
                "abc@b.fr" & @CRLF & _
                "abc@a.b.c.fr" & @CRLF & _
                "abc@a.b.c.azertyuiop" & @CRLF & _
                "a@b.fr" & @CRLF & _
                "baltazar.da-silva@douane.finances.gouv.fr" & @CRLF & _
                "toto@titi.fr" & @CRLF & _
                "tôto@tïtié.fr" & @CRLF & _
                ""tôto"@tïtié.fr" & @CRLF & _
                ""áàâäãåçéèêëíìîïñóòôöõúùûüýÿæÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝÆ"@titiéà.fr" & @CRLF & _
                ""této"@titiéà.fr" & @CRLF & _
                ""tàto"@titiéà.fr" & @CRLF & _
                ""t to"@titiéà.fr" & @CRLF & _
                "této@titiéà.fr" & @CRLF & _
                "této@194.168.12.5" & @CRLF & _
                "customer/department=shipping@example.com" & @CRLF & _
                "$A12345@example.com" & @CRLF & _
                "!def!xyz%abc@example.com" & @CRLF & _
                "_somename@example.com" & @CRLF & _
                "Loïc.Accentué@voilà.fr3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")