using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\s]+)\(dir\. ([\w\s]+) \| ([\w\s]+) \| (\d{4}) \| (\d+ min)\)(.*?)((?:\d{1,2} de [a-z]+ \| [\w\-]+ \| \d{1,2}[hH]\s*)+)";
string input = @"REDENÇÃO
(dir. Roberto Pires | Brasil | 1958 | 61 min)
Newton e Raul, dois jovens rapazes catadores de coco em um bairro pobre de Salvador, dão abrigo a um homem estranho e peculiar que chegou no meio da noite com o carro quebrado. No dia seguinte, os dois saem de casa e deixam o estranho trancado em casa; quando a noiva de Newton chega à casa no período da noite, o estranho tenta atacá-la.
21 de agosto | segunda-feira | 16h
25 de agosto | sexta-feira | 19h
30 de agosto | quarta-feira | 16h";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}