import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<URL>\\/upload(.+?)pdf).+?(?P<DATE>\\d{2}\\.\\d{2}\\.\\d{4})";
final String string = "<div class=\"rasschetSredstv\">\n"
+ "<table class=\"tab td_tac\" border=\"0\" cellpadding=\"10\" cellspacing=\"0\">\n"
+ " <tbody><tr>\n"
+ " <th width=\"17%\">Январь</th>\n"
+ " <th width=\"17%\">Февраль</th>\n"
+ " <th width=\"17%\">Март</th>\n"
+ " <th width=\"17%\">Апрель</th>\n"
+ " <th width=\"17%\">Май</th>\n"
+ " <th width=\"17%\">Июнь</th>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>\n"
+ " \n"
+ " <a target=\"_blanc\" href=\"/upload/iblock/2da/otchet_ss_310117.pdf\">Скачать</a><br>\n"
+ " pdf(201 кБ)<br> (14.02.2017 12:44:00) </td>\n"
+ " <td>\n"
+ " \n"
+ " <a target=\"_blanc\" href=\"/upload/iblock/aa8/otchet_rss_na_sayt.pdf\">Скачать</a><br>\n"
+ " pdf(196 кБ)<br> (15.03.2017 18:49:00) </td>\n"
+ " <td>\n"
+ " \n"
+ " <a target=\"_blanc\" href=\"/upload/iblock/71e/raschet_ss_na_sayt.pdf\">Скачать</a><br>\n"
+ " pdf(197 кБ)<br> (14.04.2017 18:23:00) </td>\n"
+ " <td>\n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " <td>\n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " <td>\n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <th>Июль</th>\n"
+ " <th>Август</th>\n"
+ " <th>Сентябрь</th>\n"
+ " <th>Октябрь</th>\n"
+ " <th>Ноябрь</th>\n"
+ " <th>Декабрь</th>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>\n"
+ " \n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " <td>\n"
+ " \n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " <td>\n"
+ " \n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " <td>\n"
+ " \n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " <td>\n"
+ " \n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " <td>\n"
+ " \n"
+ " \n"
+ " ----\n"
+ " </td>\n"
+ " </tr>\n"
+ "</tbody></table>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}