$re = '/([0-9]{1,})\.([0-9]{1,})\.([0-9]{1,})/m';
$str = 'Artistic Style Version 3.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);