const regex = /^(?:\d|[01]\d|2[0-3]):[0-5]\d:[0-5]\d$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d|[01]\\d|2[0-3]):[0-5]\\d:[0-5]\\d$', '')
const str = `23:59:59`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}