use strict;
my $str = '[77.30174116532164,28.63006231177832],[77.30276922561293,28.628600525419817],[77.29773173018566,28.626620040676034],[77.29166617446711,28.624309475141622],[77.28966145689911,28.623272078371073],[77.28760533631655,28.62647857748005],[77.29079232321952,28.6281289814332],[77.29212880159818,28.628506216622494],[77.2909465322632,28.629213532602414],[77.29243721968557,28.630250929372966],[77.29361948902054,28.63067531896092],[77.29577841563223,28.630863936555567],[77.29629244577787,28.63322165648864],[77.29762892415653,28.632702958103362],[77.29973644775366,28.63260864930604],[77.30163835929253,28.633646046076592],[77.30528797332657,28.632184259718088],[77.30256361355467,28.631052554150212],[77.30261501656923,28.630486701366273],[77.30174116532164,28.63006231177832]';
my $regex = qr/\d,\d
/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}