$re = '/http:\/\/www\.[a-zA-Z.-]+\/[a-zA-Z-]+[\/]{0,1}[\.a-zA-Z-]{0,}/m';
$str = 'http://www.toto.com/something
http://www.toto.com/something/else
http://www.toto.com/something/else/more';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);