$re = '/^[\S\s]*?^([^][]*=)\[\[.*\]\]\K\]\R\1\[(.*)\]$/m';
$str = '1 NameA - DirectionA=[[StreetA @ StreetB,[Lat,Long]]]
1 NameA - DirectionA=[[StreetC @ StreetD,[Lat,Long]]]
1 NameA - DirectionA=[[StreetF @ StreetE,[Lat,Long]]]
1 NameA - DirectionB=[[StreetE @ StreetF,[Lat,Long]]]
1 NameA - DirectionB=[[StreetG @ StreetH,[Lat,Long]]]
2 NameB - DirectionC=[[StreetI @ StreetJ,[Lat,Long]]]
2 NameB - DirectionC=[[StreetK @ StreetL,[Lat,Long]]]
2 NameB - DirectionD=[[StreetM @ StreetN,[Lat,Long]]]
2 NameB - DirectionD=[[StreetO @ StreetP,[Lat,Long]]]';
$subst = ", \2]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;