import Foundation
let pattern = #"(<(?:[^ >]+|.+? (["'])?.+\2)>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<foo><!foo1> 1
<foo2 bar> 2
<!foo3 bar=baz> 3
<foo4 bar="baz"> 4
<!foo5 bar='baz'> 5
<foo6 bar=baz baz="bar"> 6
<!foo7 bar="baz" baz='bar'> 7
<foo8 bar='<baz>'> 8
<!foo9 bar='<foo>' baz='<bar><baz>'> 9
<foo10 'bar'>10</foo10>
<foo11 "bar">11</foo11>
<foo12 '<bar>'>12</foo12>
<foo13 "foo<bar><baz>">13</foo13>
<foo14 "<foo bar='baz'>">foo14</foo14>
<foo15><foo16>foobar</foo16></foo15>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)