$re = '/concept(s|(ualiz(ed?|ation|ing)))?/m';
$str = 'concept
concepts
conceptualize
conceptualized
conceptualization
conceptualizing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);