import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=\\n))\\d+\\s+credits[]\\s\\S]*?(?=\\n\\d+\\s+credits|$)";
final String string = "3 credits in Philosophical Perspectives\n"
+ "PHIL 101L\n"
+ "PHILOSOPHICAL PERSPECTIVES\n"
+ "B\n"
+ "3\n"
+ "Fall 2014\n"
+ "Student View\n"
+ "3 credits in Fine Arts\n"
+ "ART 160L\n"
+ "HIST WEST ART I\n"
+ "B+\n"
+ "3\n"
+ "Fall 2014\n"
+ "3 credits in History\n"
+ "Still Needed:\n"
+ "Click here to see classes that satisfy this requirement.\n"
+ "3 credits in Literature\n"
+ "ENG 201L\n"
+ "INTRO LINGUISTIC\n"
+ "IP\n"
+ "(3)\n"
+ "Spring 2016\n"
+ "3 credits in Math\n"
+ "Still Needed:\n"
+ "Click here to see classes that satisfy this requirement.\n"
+ "3 credits in Natural Science\n"
+ "BIOL 225L\n"
+ "TOPICS IN NUTRITION\n"
+ "A-\n"
+ "3\n"
+ "Spring 2015\n"
+ "3 credits Ethics/Applied Ethics/Religious Studies\n"
+ "REST 209L\n"
+ "WORLD RELIGIONS\n"
+ "A-\n"
+ "3\n"
+ "Spring 2015\n"
+ "3 credits in Social Science\n"
+ "ECON 104L\n"
+ "PRINC MACROECONOM\n"
+ "T\n"
+ "3\n"
+ "Fall 2014";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}