re = /(?=("[^"]*"))|(?=('[^']*'))|(?=<([^<>]+)>)/
str = '<telerik:RadTab Text="RGB\'lol\'">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end