#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "CGK / WIII"
Local $sString = "LOCATION REFERENCE UPLIFT TICKET TAIL FLIGHT AIRCRAFT DESCRIPTION UOM QUANTITY UNIT EXTENDED" & @CRLF & _
" NUMBER DATE NUMBER NUMBER NUMBER TYPE" & @CRLF & _
" SHIPPED PRICE PRICE" & @CRLF & _
"" & @CRLF & _
"CGK / WIII 1208975-24101 24-MAR-21 08312411 VN-A633 VJ2432 Airbus 321 JET FUEL" & @CRLF & _
" USG -1,945.36 2.29783 (4,470.11)" & @CRLF & _
" 1208975-24101 Total" & @CRLF & _
" -1,945.36 (4,470.11)" & @CRLF & _
"CGK / WIII 1208976-24101 26-MAR-21 08517889 VN-A633 VJ2432 Airbus 321 JET FUEL" & @CRLF & _
" USG -2,802.86 2.29783 (6,440.51)" & @CRLF & _
" 1208976-24101 Total" & @CRLF & _
" -2,802.86 (6,440.51)" & @CRLF & _
"CGK / WIII 1208979-24101 28-MAR-21 08705413 VN-A633 VJ2432 Airbus 321 JET FUEL" & @CRLF & _
" USG -2,900.08 2.29783 (6,663.89)" & @CRLF & _
" 1208979-24101 Total" & @CRLF & _
" -2,900.08 (6,663.89)" & @CRLF & _
"CGK / WIII Total" & @CRLF & _
" -7,648.31 (17,574.51)" & @CRLF & _
"Grand Total" & @CRLF & _
" -7,648.31 (17,574.51)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")