package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)([^\/]+)`)
var str = `url1/url2%20ujh/url3/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}