use strict;
my $str = '<br>
<span class=""b"">拼音:</span><span class=""pinyin"">xī<script>Setduyin(\'Duyin/xi1\')</script></span> <span class=""b"">注音:</span><span class=""pinyin"">ㄒㄧ<script>Setduyin(\'Duyin/xi1\')</script></span><br>
<span class=""b"">简体部首:</span>丨 <span class=""b"">部首笔画:</span>1 <span class=""b"">总笔画:</span>8<br><span class=""b"">ç¹ä½“部首:</span>åœã€€<span class=""b"">部首笔画:</span>2 <span class=""b"">总笔画:</span>8<br><span class=""b"">康熙å—典笔画</span>( å¥:8ï¼› )';
my $regex = qr~^.*?class=\"\"pinyin\"\">(.*?)<script>~mp;
my $subst = '-';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";