package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$([a-z0-9]+)\(([^\(]+)\)`)
var str = `$upper(string1)
$lower(string2)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}