using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<koef>[+-]?\d*)(?P<literals>(?:[a-z](?:\^-?\d+)?)+)";
string input = @"x^2+y^2-4xy+6xyz-7x^3yt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}