$re = '/\[(?>[^][]++|(?R))*]/';
$str = '[e[1]] [ [e[[2]34]]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);