package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,2}[^\d]*`)
var str = `1this12string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}