re = /^(?!.*opt3)filename\.txt/m
str = 'filename.txt opt1 opt2 opt4
filename.txt opt1 opt2 opt3 opt4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end