$re = '/(([0-9a-f]{4}\-){3})/';
$str = '12af-23f4-123d-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);