$re = '/^N/m';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Cras vitae diam venenatis, aliquet risus eget, pretium mi. Pellentesque vel turpis eget massa lacinia feugiat. Aenean dolor nibh, porttitor quis eros sed, blandit malesuada orci. Proin quis ipsum at felis suscipit fermentum in in tellus. Vivamus vel vulputate metus. Ut eget molestie metus. Proin quis elit non augue egestas aliquet vel sit amet dolor. Sed tincidunt eros at imperdiet viverra. Praesent imperdiet augue nec elementum pulvinar. Nam auctor vel libero eu hendrerit. Donec urna lectus, bibendum vel turpis in, dapibus faucibus ante. Mauris quam dui, ultrices in elit elementum, semper accumsan dolor.
Nullam rutrum nisl libero, in elementum lectus suscipit sit amet. Nullam varius magna leo, ut blandit elit rhoncus vitae. Nam fringilla congue urna id feugiat. Etiam a tortor luctus, porttitor nulla sit amet, luctus sem. Praesent eleifend, quam ac porta pharetra, mauris felis sollicitudin nibh, et varius mi magna eu arcu. Morbi a dui sem. Donec convallis nibh lorem, sed venenatis enim eleifend ut. Phasellus et semper nisl.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);