#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/[^#?\/]+"
Local $sString = "https://apple.com?query=true&slash=false" & @CRLF & _
"https://apple.com#anchor=true&slash=false" & @CRLF & _
"http://www.apple.com/#anchor=true&slash=true&whatever=foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")