use strict;
my $str = '{xyz}
{xyz]
{[]}
([foo]bar)
([{bar}]baz)
([{barbar]
((a)b)
';
my $regex = qr/^( # start group 1
\(([^)(\]\[}{]+|\g<1>)*+\)| # parens & set group 2
\[\g<2>*+\]| # brackets
\{\g<2>*+\} # braces
)$ # group 1 end/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}