re = /(?x) # Free-Spacing
(?(DEFINE) # Define a few subroutines
(?<double>“(?:(?!&[lr]squo;).)*”) # full set of doubles (no quotes inside)
(?<single>‘(?:(?!&[lr]dquo;).)*’) # full set of singles (no quotes inside)
(?<notquotes>(?:(?!&[lr][sd]quo;).)*) # chars that are not quotes
) # end DEFINE
^ # Start of string
( # Start group: balanced portion
(?: # Start non-capture group
(?¬quotes) # Any non-quote chars
&l(?<type>[sd])quo; # Opening quote, capture single or double type
# any full singles, doubles, not quotes or recursion
(?:(?&single)|(?&double)|(?¬quotes)|(?R))*
&r\k<type>quo; # Closing quote of the correct type
)*+ # Repeat non-capture group
) # end balanced portion
\K
(
(?¬quotes)
&r([sd])quo; # unmatched quote
)/
str = '“Full Quote” The Left Quote is Missing”
'
subst = '&l\\7quo;\\6'
result = str.sub(re, subst)
# Print the result of the substitution
puts result