re = /^{([^{}]*|{([^{}]*|{([^{}]*|{})*})*})*}$/m
str = '{ abc }
{ a { bc } }
{ a {{}} }
{ a b cde }{aa}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end