package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:,\s*\S+){3}`)
var str = `Chrysanthemum.jpg, Desert.png, Hydrangeas.gif, Jellyfish.jpg, Koala.jpg, Lighthouse.png,`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}