$re = '/(\d+)(?=(?:.(?!\())*\))/';
$str = '21 [42] (12) 19 25 [44] (25 26 27) 17 (14 3) 8 1 6 (19)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);