$re = '/[a-zA-Z]+(,\s*[a-zA-Z]+)*/';
$str = 'keyword1,keyword2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);