re = /\[(?:\[[^\[\]]*\]|[^\[\]])*\]/m
str = '[COUNT([Weight]) > 10] < 20 [COUNT([Weight]) > 10] < 20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end