$re = '/^([a-zA-Z]++ *+)++$/';
$str = 'dssdfsdfdsf wdasdads dadlkn mdsds .';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);