import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\b[^>]*href\\s*=\\s*\"cid[^\"]*\"[^>]*>.*<\\/a>";
final String string = "<html>\n"
+ "<head>\n"
+ "<meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\">\n"
+ "<meta name=\"Generator\" content=\"Microsoft Exchange Server\">\n"
+ "<!-- converted from rtf -->\n"
+ "<style><!-- .EmailQuote { margin-left: 1pt; padding-left: 4pt; border-left: #800000 2px solid; } --></style>\n"
+ "</head>\n"
+ "<body>\n"
+ "<font face=\"Arial\" size=\"2\"><span style=\"font-size:10pt;\">\n"
+ "<div>notes</div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\"><img src=\"cid:0DF540471453B832E300400FF03B0900CFEC1201@1\"> <a href=\"cid:74D8EEA6180AD131B48DC59373FABBABD7E361BB@1\">GoodGEMSinstall.docx</a> </span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\"> </span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\"><b>some</b> <span style=\"background-color:yellow;\">formatted</span> <font size=\"6\" color=\"red\"><span style=\"font-size:22pt;\">text</span></font></span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\" color=\"red\"><span style=\"font-size:11pt;\"> </span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\"><a href=\"cid:A559E9B55081418F53A3B0914D29351714C64825@1\">PowerShell_transcript.20140506143510.txt</a> </span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\"> </span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\"><a href=\"http://www.google.com\"><font color=\"blue\"><u>www.google.com</u></font></a></span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\"> </span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\">some links <a href=\"http://www.test.fr\"><font color=\"blue\"><u>www.test.fr</u></font></a> </span></font></div>\n"
+ "<div><font face=\"Calibri\" size=\"2\"><span style=\"font-size:11pt;\"> </span></font></div>\n"
+ "</span></font>\n"
+ "</body>\n"
+ "</html>\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}