$re = '/^(?<!_)[a-z-]*\.(sass|less|scss)$/m';
$str = 'file.sass
_file.sass';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);