// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi) <a id="(.*?)<\/a>"#).unwrap();
let string = "{% comment %}
Use this template to create the Appian_Release_Notes.md page for each new version of Appian. Any changes to this template should be discussed with the Information Development team.
{% endcomment %}
New features are described below in detail. Behavior changes, resolved issues, deprecations, and removals are called out their own sections.
{% comment %}
### <a id=\"Example_New_Feature\"></a> Example New Feature ###
This is a short description of the new feature. Group two or more closely related features using a common section with h4 subsections. Link to associated documentation as shown below (based on the number of links).
See also: [Associated Documentation](Associated_Documentation.md)
See also: [Associated Documentation](Associated_Documentation.md) and [Associated Documentation](Associated_Documentation.md)
See also: [Associated Documentation](Associated_Documentation.md), [Associated Documentation](Associated_Documentation.md), and [Associated Documentation](Associated_Documentation.md)
{% endcomment %}
## <a id=\"User_Interfaces\"></a> User Interfaces ##
This section describes new features for user interfaces, including Tempo, sites, and embedded interfaces.
### Sites Revolution ###
#### <a id=\"Tempo_Reports_in_Sites\"></a> Tempo Reports in Sites ###
In addition to task reports, actions and record types, designers can now configure sites to have Tempo reports. Making it easier for sites only users to view and analyze data.
<img class=\"screenshot\" src=\"images/release_notes/SitesTempoReports.png\"/>
[configure sites with reports](Sites.md#Configure_a_Site_Page).
#### <a id=\"Inline_Task_Management\"></a> Inline Task Management ###
Task management has improved for users of all Appian user environments. All task management controls for SAIL [tasks](Tasks.md), including save changes, reassign, and reject, have been moved to above the task form.
The left-hand navigation bar no longer appears in Tempo when viewing SAIL tasks, allowing task forms to occupy the full page width.
These task management controls are now available to [sites](Sites.md) users for the first time.
Users of [embedded](Embedded_Interfaces.md) tasks now have the option to save changes to SAIL tasks.
<img src=\"images/release_notes/InlineTaskControls.png\" class=\"screenshot\"/>
#### <a id=\"User_Record_in_Sites\"></a> User Record in Sites ###
We have made it possible for designers to configure the User record and User record links in sites.
<img class=\"screenshot\" src=\"images/release_notes/SitesUserRecord.png\"/>
#### <a id=\"User_Profile_in_Sites\"></a> User Profile in Sites ###
Users can now update their profiles in a site by clicking on their avatar in the header and clicking on the Profile button.
<img class=\"screenshot\" src=\"images/release_notes/SitesUserProfile.png\"/>
#### Wider Sites ###
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}