re = /'\(?(https?\:\/\/|redir\.aspx\?)([\w\d\.\=\/\?\-]+)\)?'/
str = 'prvs=0996c920be=shana.devolder@geldof.be'
# Print the match result
str.match(re) do |match|
puts match.to_s
end