$re = '/@\D+\K(\d+)/m';
$str = 'This is a test @VVC345RR, text, and more text 12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);