$re = '/^(?![0-9]+(\.[0-9]*)?(?=,))[^,]*(?=,)/m';
$str = '100,0
2245.1250,0
12.,0
text,0
2texxtk,0
2tekas02,0
2.51knd12.4,0
}{tr201mns.02,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);