const regex = /(^.*?\d{4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*?\\d{4})', '')
const str = `heldodd123helo1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}