$re = '%\b[-\p{L}]{1,5}\b%u';
$str = 'Из-за моря, из-за гор прилетел гиппопотам';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);