$re = '%\b(?<!-)(?=\p{L}) # начало слова
[-\p{L}]{1,5} # слово
\b(?<=\p{L})(?!-) # конец слова%ux';
$str = 'Из-за моря, из-под гор прилетел гиппопотам
пум- пум_ -пум
пам1 2пам парам;
p2p peer to peer.
п---п';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);