$re = '/(?=.*\S\#)(.*\#\w{1,5}\b)/m';
$str = '#car2 should pass
\'Rock#car2\' should pass
\'R o ck#car2\' should pass
\'Rock #car2\' should fail
\'Rock#car12345\' should fail
\'Rock#\' should fail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);