re = /(<meta property="og:image" content=")(.+?)(?:)">"/m
str = '<meta property="og:image" content="https://m.media-amazon.com/images/M/MV5BYWFlZGY2NDktY2ZjOS00ZWNkLTg0ZDAtZDY4MTM1ODU4ZjljXkEyXkFqcGdeQXVyMjUzOTY1NTc@._V1_UY1200_CR79,0,630,1200_AL_.jpg">"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end