$re = '/\b(?:\w )+\w\b/m';
$str = 'This is an e x a m p l e sentence.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);