re = /sandwich((?:(?!forbidden).)*?)(ham|turkey)/
str = 'reuben sandwich with ham and turkey ham sandwich with cheese
reuben sandwich with forbidden ham and turkey ham sandwich with cheese
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end