package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bEmpId=(\d+)&`)
var str = `"http://localhost/Employee/EmployeeMgmt/EmpDetails.aspx?EmpId=784657&From=Information Technology";
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}