$re = '/^[0-9]{3}[\ ]{0,1}[0-9]{3}[\ ]{0,1}[0-9]{4}$/';
$str = '123 456 7890';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);