package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{1,2}\/[0-9]{1,2}\/[0-9]{2,4})([a-zA-Z\s]+)`)
var str = `05/21/2018 ghijkl 10/12/2017 mnopqrst`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}