$re = '/^(?:https?)?:?\/\//m';
$str = 'https://
opacity:0; ://
text-align: right;
//google.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);